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Tips to make reports with 
Enif graphics

Shane Velan
INRO Consultants
 

This is a revised version of the paper originally presented at the 12th European EMME/2 
Users' Conference in Basel, Switzerland on 22-23 May 2003.

Enif is software used to access EMME/2 data banks with a modern interface. This 
presentation includes tips on generating output from Enif and discusses alternative graphic 
formats for the preparation and distribution of reports. 

The graphics included in this presentation are to be displayed directly from OpenOffice 
Impress or to be printed in color directly from OpenOffice Impress for distribution. 
Conversion of this presentation into PDF form from OpenOffice 1.0.2 introduces distortion: 
the quality of the graphics is equivalent to JPEG at 50% compression. Conversion of this 
presentation into web format necessitates that the graphics be saved in JPEG or GIF format, 
which also introduces distortion.

Graphics were generated in various graphic file formats using an Intel PC with Windows XP 
and the most recent official release of Enif, version 1.0. This presentation itself serves as an 
example of how Enif images in various formats can be incorporated into a presentation.

Online references:
- Graphic file formats at a glance       acomp.stanford.edu/acpubs/Docs/graphic_file_formats/
- PostScript vs. PDF        www.adobe.com/print/features/psvspdf/main.html
- The Official Free PDF Support Site        www28.brinkster.com/freepdfsupport/index.html
- How to Create Adobe PDF Files for Print and Press
      www.adobe.com/products/postscript/pdfs/pdfforprint.pdf
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Contents of presentation

Types of reports
Raster graphics
Vector graphics
Graphics format recommendations
Tips for Enif output

These notes (i.e. below the presentation slides) serve the purposes of 
  - documenting the oral content to the presentation, 
  - providing additional technical content, and
  - supplying details so that the audience may replicate the graphics presented.

This presentation does not comprehensively define graphic file formats. The definition and 
description of the various graphic formats is limited to those aspects which are relevant to 
producing reports with Enif graphics.

Demonstrations are included to cover the following activities
  - generation of graphics of Enif plots, 
  - manipulating those graphics, 
  - inserting the graphics into report-creation software, and 
  - saving the reports for distribution.

The appendix details various software installations and the procedures used to generate the 
graphics discussed in this presentation.
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Types of reports

How will the audience be reached?
Print the report
Post an HTML report
Distribute the report in electronic PDF format
Present the report live

Understand the limitations of the software, 
hardware, and materials used to generate 
reports. 

Understand the limitations of the software, hardware, and materials used to generate reports. 
How will the reader access the report?

Printed report
  - Identify the image-handling capabilities of the software used to create the report.
  - Test that the colors are distinguishable if printed in black & white.
  - Choose the paper size, e.g. A4, letter, or large format.
  - Choose a paper type that works with your printer and its ink.

Browse an HTML report
  - Which browser? Different browsers support only certain image formats and may render 
HTML or process scripts with differences that effect the appearance and functionality of your 
page. Poll your audience to determine which browsers are used.
  - Design the layout to fit the resolution of the monitor.
  - Should the report be printable? Browsers do not print HTML consistently. See electronic 
distribution below.

Electronic distribution in PDF* format
  * PDF files are viewable with Abode Acrobat Reader, available at no charge. Other formats 
that require the purchase of software to view the file are discouraged.
  - Consider the same issues as a printed report, plus...
  - Generate the report in PDF format. (FreePDF-generation software is discussed later.)

Presentations
  - Identify the image-handling capabilities of the software used to create/present.
  - If presented with printed slides, choose a slide compatible with your printer and ink.
  - If presented with a projector, note the limitations of projector resolutions
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Raster images

A raster graphic is a graphic drawn as an 
array of colored dots. 
Advantages

fast screen rendering
compact for photos

Disadvantages
not scalable
loss due to compression depending on format
potentially very large files
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Raster image formats
Format name .ext Color Compression Transparency

bitmap BMP max 24-bit RGB
joint photographic experts group JPEG 24-bit RGB

portable network graphics PNG yes

portable bitmap PBM 1-bit monochrome
portable graymap PGM 8-bit grayscale

portable pixmap PPM 24-bit RGB

X bitmap XBM 1-bit monochrome
X pixmap XPM 24-bit RGB lossless

graphic interchange format max 8-bit lossless yes
tagged image file format 24-bit RGB lossy & lossless yes

*proprietary formats not supported by Enif
* file size is affected by Enif's Quality setting
*Enif output is 24-bit RGB

lossy*
max 48-bit* lossless*

GIF*
TIFF*

Eight bits is adequate for 256 colors or 256 shades of gray. RGB color capability requires 24-
bits: 256 shades each of red, green and blue to yield 16.7 million colors. If a limited color 
palette is used, then 8 bits is adequate and 24-bits is wasted memory.

Lossy compression reduces the file size at the expense of image quality. JPEG lossy 
compression (optionally supported in TIFF) distorts sharply contrasting boundaries.

Lossless compression reduces the file size at the expense of rendering speed. The image 
quality is not affected. Lossless compression is efficient for images with areas of homogeneous 
color, such as drawings.

Transparency is useful for annotations in Enif. For example, highway number symbols are not 
square shaped.
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Sample plot

This sample image was used to demonstrate the qualitative and quantitative comparison of 
various image formats. The small black rectangle was enlarged to make the differences visible.

This image is the Enif plot configuration, found in the Plots menu under
  Winnipeg plot configurations > Transit network and results > Transit line load profile
with the following settings 
  - predefined view: Whole network
  - removed wallpaper background
  - generated a file for each graphic format with commands Export print view to image file 
or Print current view from the File menu
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Image formats 
with lossless/no compression

 BMP (Win) 100%
 PNG (All) 100..1%
 PPM (Unix) 100%
 XPM (X Win) 67%

 PGM (Unix) 33%  PBM (Unix) 4%
 XBM (X Win) 22%

The numbers are the relative file sizes, where the whole image has size 100 = 1 978 818 bytes 
≈ 2Mb.

The PNG image format has lossless compression, which reduces the file size at the expense of 
rendering speed. The file size of this image was reduced by 99%.

PNG is the preferred format for raster images as long as the software being used to display the 
report with Enif plot images supports the PNG format. For example, Internet Explorer 4 and 
Netscape 4 do not support PNG at all. IE 6 renders PNG images, but does not handle PNG 
transparency.
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Converted raster graphics

BMP format
relative file size 100%

GIF format
relative file size 3%

TIFF format
relative file size 5%

Enif does not support the GIF or TIFF formats. The BMP file was resaved as a GIF file and a 
TIFF file.

The GIF format supports only 8-bit = 256 colors. Note the approximated green color. If the 
Enif plot uses only the standard web colors, then converting the image to GIF will yield no loss 
of quality.

TIFF supports lossless compression. Note that there is no distortion in the converted TIFF 
image. Support of the TIFF format by various software is better than for PNG now, so 
converting Enif PNG images to TIFF is a good alternative.
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Sample plot 
with a background image

The satellite photo is a JPEG image used as a background image in this Enif plot configuration.

This image is the Enif plot configuration, found in the Plots menu under
  Winnipeg plot configurations > Demand > Desire lines between zones
with the following settings 
  - Full view
  - files generated with File menu items Export print view to image file or Print full view
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JPEG lossy compression

BMP format
 

relative file size 100%

JPEG format
Quality 100

relative file size 12%

JPEG format
Quality 75 (default)
relative file size 4%

The BMP format serves as a consistent benchmark because it does not support compression.

The JPEG lossy compression was designed for images with continuously varying gradation, 
such as photos. The distortion of photographic images is acceptable when weighed against the 
savings in file size. Note the distorted background image. The distortion of text and shapes 
with high contrast makes JPEG a poor choice as an export format for most Enif plots.
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Demonstration:
Enif raster graphics

export an image in Enif
adjust the Enif window size
select “Export...” from the File menu
specify the graphic format with a file name extension
set the Enlargement
set the Quality (affects only JPG and PNG)

add the image to a web page
do not resize the image

To save an image (raster format) in Enif:
  - Fix the proportions of the view port by adjusting the size of the Enif window. Check the 
dimensions of the view port with the tool tip of the pan panel.
  - Select Export screen view to image file or Export print view to image file from the 
File menu.
  - Set the Enlargement factor (up to 8) to increase the image resolution. The processor time 
and the file size increase with the square of this factor, so do not use bigger enlargement 
factors to be on the sure side!
  - Set the Quality from 0 for maximum compression to 100 for no compression. The Quality 
setting affects only the JPEG and PNG formats. The quality and the file size decrease for a 
JPEG file, where the default Quality is 75. Only the file size decreases for a PNG file; the 
quality remains the same. The default Quality has a value of 30 for a PNG file.
  - Enter the file name with the correct extension.

Post-processing a raster graphic:
  - Avoid post-processing the image to obtain the best quality raster graphics: adjust the Enif 
window and set the Enlargement factor appropriately before exporting the image from Enif.
  - Resizing a raster graphic will distort the image. Resizing is accomplished by resampling 
(throwing away pixels) or interpolation (estimating the color of added pixels). Resizing can be 
done with Microsoft Paint or by specifying attributes of the HTML <img> tag, such as width 
and height.
  - Rescale/resample a graphic to increase the resolution for printing. Rescaling can be done 
with Jasc Paint Shop Pro, Adobe Photoshop, and other image manipulation software, but not 
Microsoft Paint.
  - A raster graphic can be easily cropped with any image manipulation software.
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Vector graphics
A vector graphic is a graphic drawn as lines, 
polygons and text. 
Advantages

scalable
compact for images composed of geometric shapes

Disadvantages
generating vector graphics requires additional 
software with careful configuration (on Windows)
displaying vector graphics requires specific software 
and can be computationally expensive
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Vector graphics formats

PostScript
a page description language designed to describe 
accurately the appearance of a page
a proprietary format owned by Adobe
commonly stored in PS, EPS, and PDF files
a Raster Image Processor (RIP) interprets textual 
PostScript code as dots

examples of other vector formats
CGM: computer graphics metafile
WMF: Windows metafile 
DXF: AutoCAD

All PostScript-compatible printers have a Raster Image Processor (RIP). Displaying a .ps file 
on the screen requires a viewer with a RIP, such as Ghostscript with GSView, and can be 
computationally expensive. Only high-end (expensive) publishing software have a built-in RIP 
to view and manipulate .ps graphics. It is more convenient to work with a raster preview of the 
graphic, which is embedded in the EPS format. EPS also simplifies the display of a vector 
graphic with a bounding box. 

Some programs that can import EPS graphics: 
  - Microsoft Word 2000+ *
  - Microsoft PowerPoint 2000+ *
  - OpenOffice 1.0+
  - Quark Express
  - Adobe Photoshop, Illustrator, InDesign...
* MS Office 1997 claims to import EPS files, but I had limited success with EPS files in Word 
'97 and Powerpoint '97.
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PS and EPS file formats

PS was designed for consistent, accurate 
printing of an entire file.
Encapsulated PostScript files can be 
inserted into report-generating software 

may contain an encapsulated raster preview image
a bounding box identifies the relevant portion of the 
page

Printing PS and EPS requires a PostScript 
printer.

Excerpt of a PS file: Excerpt of an EPS file:
%!PS-Adobe-3.0 %!PS-Adobe-3.0 EPSF-3.0
%%Title: MS Shell Dlg %%Title: MS Shell Dlg
%%Creator: PScript5.dll Version 5.2 %%Creator: PScript5.dll Version 5.2
··· ···
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PDF file format

Portable Document Format
PDF is a PostScript file interpreted by a RIP into 
objects
PDF can also contain printing instructions, keywords 
for searching/indexing, hyperlinks, animation, etc.

Advantages over (E)PS
smaller file size
printing PDF does not require a PostScript printer

Disadvantage
cannot insert PDF images into most report-creation 
software

Portable Document Format is an alternative format for PS files and EPS files. PDF can contain 
information related to how a page looks, and can describe how it behaves and what kind of 
information is contained in the file. A PDF file can contain fonts, images, printing instructions, 
keywords for searching and indexing, job tickets, interactive hyperlinks, movies, etc.
  - Adobe Acrobat Reader (free) can print PDF to non-PostScript printers by interpreting the 
PDF file into that printer's language.
  - Disadvantage of PDF: cannot insert PDF images into most report-creation software
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Raster v. vector graphics

BMP format
relative file size 100%

PS/EPS format
relative file size 1108%

+EPS preview

PDF format
relative file size 46%

Vector graphics provide far better image quality due to unlimited scalability, which takes 
advantage of the best possible resolution of the output device.

The above PostScript graphic was generated with Enif using the Adobe PostScript Driver. 
The background satellite image yielded a PS file requiring over 10 times the storage capacity 
of the bitmap format. The other Enif sample plot (without a background photo) resulted in a 
relative file size equal to 43 when saved to PS. The conversion of PS to EPS has minimal 
impact on the file size. Adding a raster preview image can result in an arbitrarily larger EPS 
file.

The above PDF graphic was generated with Enif using FreePDF. The PDF format is of 
comparable quality to the PS/EPS format, with a much smaller file size. The other Enif sample 
plot resulted in a relative file size equal to 3.
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Demonstration:
Enif vector graphics

Print an Enif plot to PDF
cannot easily include the PDF image in a report

Print an Enif plot to PS
convert PS to EPS
add an EPS preview

Insert the EPS image into a report
save the report to PDF format

To save a PS graphic in Enif in Windows (Appendix B)
  - Select Print full view or Print current view from the File menu. Select the previously 
installed printer called “PostScript Generator”. Check the print to file checkbox in the print 
manager. Specify a file name with extension “.ps” when prompted.
  * If fonts do not scale properly or if fonts change when saved to a .ps file, you may not be 
using scalable fonts. Specify fonts that are TrueType or OpenType in the Enif Preferences. 

Generating a PDF from Enif (Appendix A)
  - In Enif, select Print current view or Print full view from the File menu, and select the  
previously installed printer called “FreePDF - Acrobat Distiller”. Leave print to file 
unchecked. Click Print. Follow the instructions in the FreePDF dialog to save the PDF file.

Generating a PDF from any software:
  - Select Print from the File menu, and select the  previously installed printer called 
“FreePDF – Acrobat Distiller”. Leave print to file unchecked. Click Print. Follow the 
instructions in the FreePDF dialog to save the PDF file.
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Graphics format 
recommendations

Printed reports should use vector graphics.
insert EPS images into the report
save the report to PDF

Printed reports can use raster graphics
resolution for printing images (300-600dpi) leads to 
huge file sizes, so use PNG or convert to TIFF

Web sites should use raster graphics
use PNG if possible
alternatively, use a limited color palette and convert 
from PNG/BMP/PPM/XPM to GIF
not recommended: JPEG 

Although vector graphics are recommended for printed reports, if the report creation software 
cannot accommodate insertion of EPS images, then it is necessary to use raster graphics. See 
Appendix E for an example.
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Tips for Enif output
Plot size

Enif window
Enlargement factor

Different screen and printer output
mapper flags
out-of-screen print legends
stylus pen width 0

Print Preferences
applied only after a new session of Enif is opened

Now that we know how to output Enif plots to useful formats, how can we use Enif to obtain 
the images we want?

Plot size
  - The network plane dictates the size and proportion of the exported image or printed plot.
  - To reduce the plot size, you may need to hide parts of the Enif interface (in configuration 
mode) with Options > Show ... 
  - The tool tip of the pan panel displays the size of the view port. 

Different screen and printer output
  - Mapper flags can select whether or not the layer is displayed on the screen, in the 
magnifier, or when printed.
  - Out-of-screen print legends are useful for including a title, a legend, or a logo outside of the 
printed plot frame. 
  - The stylus pen width 0 uses the minimal line width of the output device: 1 pixel on a screen 
or 1 dot on a printer.
  - Check the printer output on the screen by printing to a .ps file and viewing the result with 
GSView.

Print Preferences 
  - applied only after a new session of Enif is opened
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Appendix A: Generate PDF in Windows
To generate a PDF graphic with Windows software install Adobe Acrobat 
(US$249+) or follow the directions for Windows 9x/2000/XP to install (at no cost) 
and configure Redmon, FreePDF, and an Adobe PostScript Printer Driver at 
http://www28.brinkster.com/freepdfsupport/

Use GNU Ghostscript 7.05 since an error occurred when generating the 
PDF using FreePDF 0.98f with APFL Ghostscript 7.03, 7.04, and 8.00. 
APFL and GNU refer to copyrights. Both are free. See details at 
http://www.cs.wisc.edu/~ghost/doc/faq.htm#afpl_gnu
Download GNU Ghostscript 7.05 from 
ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/gnu/gs705/
See Appendix B for details on installing the Adobe PostScript Printer Driver.
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Appendix B: Generate PostScript in Windows
To generate a PostScript graphic in Windows install Adobe Acrobat (US$249+) 
or install the Adobe PostScript Printer Driver free of charge as follows:

Download (at no cost) the Adobe Universal PostScript Windows Driver 
Installer 1.0.6 and PPD Files: Adobe from www.adobe.com. Extract the 
PPD Files: Adobe archive to the hard drive.
The recommended system requirements refer to an installed PostScript 
printer, which proved unnecessary in our tests.
Install the Adobe PostScript Printer Driver locally on LPT1. Browse to 
Acrobat Distiller in the unzipped archive of PPD files to select the printer 
model. Name this printer "PostScript Generator".
Tests at INRO showed that the following was necessary to have the image 
printed on the PostScript printer: in the Printing Properties of the PostScript 
Generator printer, in the advanced options, in the PostScript Options, set 
the PostScript Output Option to Encapsulated PostScript (EPS), and set 
the TrueType Font Download Option to Bitmap. 

All Windows software, including Enif for Windows, prints via the Windows Print 
dialog. Choose the PostScript Generator printer and check the print to file 
checkbox. Click Print. Specify the path and the file name with extension “.ps”.

If fonts do not scale properly or if fonts change when saved to a .ps file, you 
may not be using scalable fonts. Specify fonts that are TrueType or 
OpenType in the Enif Preferences. 
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Appendix C: Convert PS to EPS in Windows

To view a PS file, install Ghostscript and GSview. Visit 
http://www.cs.wisc.edu/~ghost/

See Appendix A for details.

Converting PS to EPS in Windows:
Open the .ps file with GSView. From the File menu select PS to EPS. 
GSView can automatically select the bounding box, or you may specify it 
with mouse clicks. Specify a file name with extension “.eps” when 
prompted. 
Open the .eps file with GSView. Select Add EPS Preview from the Edit 
menu and choose a format. Specify a different file name with extension 
“.eps” when prompted.
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Appendix D: Generate EPS in Linux/Unix

To save an EPS graphic from Enif in Unix/Linux
Select Preferences from the Edit menu. Select the Print tab and check the 
Margins applied to full page checkbox. This ensures that the output is 
portable and is not printer dependent, since printers have different printable 
areas.
Select Print full view or Print current view from the File menu. The output 
generated is EPS (1st line: %!PS-Adobe-1.0 EPSF-3.0).
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Appendix E: Using raster images in reports
If the report creation software cannot accommodate insertion of EPS images, 
then it is necessary to use raster graphics. The following tips will help.

The resolution of the generated image depends on the screen resolution. 
The screen resolution is 72 or 96 dpi (dots per inch). Check the screen 
resolution by exporting an image from Enif, then checking the resolution 
with an image editor. For example, open the image with Paint and select 
Attributes from the Image menu.
Use Enif's Enlargement factor in the export plot to image file dialog to 
generate an adequate number of pixels for good quality printing. Adequate 
print resolution is usually 300 to 600 dpi. If the required graphic measures 
20 cm in width on the printed page at 300 dpi, it is necessary for the image 
to have a width of 2362 pixels. Adjust the Enif window so that the view port 
is 787 pixels wide according to the pan panel tool tip. Set the Enlargement 
factor to 3 when exporting the plot image from Enif.
To maximize print quality, avoid adjusting the resolution of the image. If it is 
unavoidable, adjust the resolution of the image with the report-creation 
software if possible, for example Quark Express. If the report creation 
software cannot adjust the image resolution, then use a graphics editing 
program to increase the resolution by resampling the image. Paint cannot 
perform this operation. Use Paint Shop Pro from Jasc or Adobe Photoshop 
or a similar software.


